Ask a Question

particulars field

Is there any way to add more detail to the particulars field other than the system generated code? I am using the personal app. Thanks

App Secret for Personal Apps

Hi there, Do personal apps come with an app secret when created? Or is that only for the paid accounts? <br> Cheers.

Endpoints not returning any data

Hi, I've attempted to use the /transactions endpoint and the /accounts endpoint with my personal app; it does have permissions to these endpoints. However, I just received responses with empty lists in the items parameter of the response. I am using Kiwibank for this; I am unsure if I have done something wrong or what is happening because I get successful responses but just no data.

Client side /me GET and CORS denial

I am testing the /me API with a Personal App using `fetch`(as per docs <https://developers.akahu.nz/reference/get_me>) but only receive a CORS denial as I assume localhost is not white listed. My app and user tokens are correct as the API reference example works but running this locally does not work via Node Live Server. Have tried on a hosted environment with valid SSL and still get the same problem due to no domain white listing. Am I missing a step here?

ASB foreign currency accounts not showing transactions

I am using the Personal App to connect to my ASB account. My ASB foreign currency accounts are not showing any transactions via the Akahu APIs, although I have many transactions clearly visible in the bank webapp. I assume this is a bug at your end; could you please have a look at this? I'm happy to provide debugging information if needed. FYI I have tried several accounts each with a different foreign currency and all with the same problem. I have tried access via the following endpoints, successfully invoking each time but with empty results returned for the accounts in question: <https://api.akahu.io/v1/transactions> <https://api.akahu.io/v1/accounts/{acc_id}/transactions> <https://api.akahu.io/v1/accounts/{acc_id}/transactions/pending>

WEBHOOK Event not receiving

Hi , I implement the user webhook subscription successfully. But once I revoke access from akahu. I am not receiving any request from akahu on my provided webhook api end point. I have provided webhook restfull api post url. I also try the webhook events api with sent/fail/retry status it returns empty list. What I am doing wrong?

Where to set webhook url

I want to set multiple webhooks url for multiple env. Help is appreciated.

Unable to Transfer between accounts of two different user on my dev app

I am trying to transfer amount from user A connected akahu account to user B connected Akahu account. it always give me invalid destination account response. But I can make transfer from user A's one account to another account. Is it possible that I can make transfers between different user connected accounts???

Unable to make payment

Is there any way I can make transfer from the account, I have been unable to make transfer out to other account

Payment Permission

Is there a way to disable Payment Permission? It seems like it's on by default and can't be unticked? I want to make sure there is no way to create payments through the platform.